pmTarget

Description

pmTarget is a tiny utility to send commands to panelman to be able to clear/run panels.

Command Line

This is simply the raw string to send to Infodriver 998 (the navigation infodriver) for the slot read by this app which defines your workstation number (i.e. CC_WORKSTATION).

Clearing Panels

From panelman 4.6.7.0 supports the PA /CLEAR command (note: PA not PX) which does the same as the clear button on the panelman user interface.

Running Panels

Either run panels by trying to "adjust" an instance with PA <instance_name>. Or execute panel with PX <panel> where the path is relative to the system's panel directory.

E.g. for a panel:

W:\core_system\panels\examples\tutorial_7

call:

pmTarget.exe examples\tutorial_7

Compiler Settings

For ease of satisfying dependencies pmTarget is unusually placed in the windows\lib folder of your system.

You should refer to the environment variables in the path to the app rather than rely on Visual Studio propagating the environment variables (this is because it doesn't!).

Visual Studio 6

The following step is a custom-build step placed on the header of the project. This doesn't need a custom build step but ensures that this gets called early on in the build:

Note: PA /CLEAR

The full line (not visible in the screnshot) is:

$(CC_ROOT)\$(CC_SYSTEM)\windows\lib\pmTarget PA /CLEAR

The following step is a post-link step to re-launch the panel in panelman:

Note: PX <appPath>

The full line not visible in the screenshot is:

$(CC_ROOT)\$(CC_SYSTEM)\windows\lib\pmTarget PX examples/tutorial_7

Visual Studio 2013

This is slightly more straightforward than VC6 as VS2013 has pre-build and post-build steps - these require the same values noted above.

Application Path

Visual Studio strips all environment settings before launching the app. so it is unable to pick up "normal" BNCS application dependency. To make this easy to handle the app resides in windows\lib to ensure that dependencies are all local.

Do not be tempted to add the path to Visual Studio's executable paths options - this makes your code not portable between machines.

Version Control

Version | Date | Author | Comments
1.0 | 27/02/2017 | David Yates | Conversion to markdown
Build: master 3586 0d983c63 Atos © 2018