ccDriverTest

ccDriverTest - Generic Driver Simulator App

Description

The purpose of this application is to simulate some or all of a system for testing purposes.

Write to it and it'll respond and persist the value, and respond in whatever way you asked. i.e. if you info poll you'll get info responses.

It's "well behaved" in that it'll always defer TxRx status to any other app on the network, and won't register devices that are already locally registered.

This app is fine to run hundreds of devices on a single workstation but will start to struggle if you ask for thousands. Absolute tops is thereabouts of 9900.

Configuration

This app. used to just run up all 999 BNCS devices - and still does by default, but extended ranges mean this is no longer possible so the following command line options have been added.

/min=<device>

Set the minimum device number to run up. You must also supply the max parameter.

/max=<device>

Sets the maximum device number to run up. You must also supply the min parameter.

So to run up devices 10001 to 11001 you'd use the command line:

ccDriverTest.exe /min=10001 /max=11001

/maxloglines=<num-lines>

The maximum number of lines the logging control on the dialog should show

Importing data from CapLog files

If you drag and drop caplog files this application will read "revertive" messages and store the last one it sees in the caplogs you give it as the current value.

It's smart enough to order standard CapLog files in date order to ensure you can drop multiple files at once.

Files should be of the (standard) format:

LOG_20180313.19

and it'll load data from entries of the format:

19:02:50-17 - [001] IR 402 355 '0' [011]
19:02:51-16 - [001] RR 1 141 1 [011]
19:02:57-16 - [001] GR 1 22 0 [011]

but ignore everything else

Version History

Version | Date | Author | Notes
(none) |  | DY | First Version (no version resources)
1.0.2 | 15/10/2017 | DY | Makes work with full range of slots/devices
1.0.3 | 15/01/2018 | DY | Tiny fix to range of devices used (so you can use a single device if yer want). Small note above the max number of devices
1.0.4 | 13/03/2018 | DY | Now understands caplog files if you drag and drop them on the application
Build: master 3586 0d983c63 Atos © 2018