bncs_netviewer

DDS BNCS Net Viewer (CapLog)

Description

This is a technology evaluation application.

Like CapLog...but not...

Is router modify device-database-index or device-index-database? GPI switch commands/revertives has state or index first?

With this application it's ALWAYS device-index (though you may want to think of it as device-destination)

What the display means

Display | Meaning | Notes
RC 123 456 789 ',---' 2 | Router Crosspoint device=123 dest=456 source=789 mask=,--- workstation=2 |
RP 123 456 789 2 | Router Poll device=123 start=456 end=789 workstation=2 |
RL 123 456 1 2 | Router Lock device=123 dest=456 state=1 workstation=2 |
IW 123 456 'Stuff' 2 | Info Write device=123 dest=456 value=Stuff workstation=2 |
IP 123 456 789 2 | Info Poll device=123 start=456 end=789 workstation=2 |
IL 123 456 1 2 | Info Lock device=123 dest=456 state=1 workstation=2 |
GS 123 456 1 2 | GPI Switch device=123 dest=456 state=1 workstation=2 |
GP 123 456 789 2 | GPI Poll device=123 start=456 end=789 workstation=2 |
GL 123 456 1 2 | GPI Lock device=123 dest=456 state=1 workstation=2 |
RM 123 456 789 'Stuff' 1 2 123456 | Router Modify device=123 index=456 database=789 name=Stuff tallyDump=1 workstation=2 applicationHandle=123456 | Application Handle is used internally to prevent howlround on this peer-to-peer message when used on FABIAN/Slink links
RR 123 456 789 2 | Router Revertive device=123 dest=456 source=789 workstation=2 |
IR 123 456 'Stuff' 2 | Info Revertive device=123 dest=456 info=Stuff workstation=2 |
GR 123 456 1 2 | GPI Revertive device=123 dest=456 state=1 workstation=2 |
NC 123 2 | Net Close device=123 workstation=2 |
NO 123 2 3 | Net Objection device=123 sourceWorkstation=2 destWorkstation=3 |
NI 123 2 | Net Inquiry device=123 workstation=2 |
NV 123 2 121 | Net Slave device=123 sourceWorkstation=2 masterDevice=121 |
NB 123 2 | Net Broken device=123 workstation=2 |

UI Options

Consider the following example:

This shows the toolbar.

Item | Notes
Clear | a button to remove all items from the list
C | toggles display of control messages - these are the core BNCS messages to write values, get responses, set cross points etc. In this example this is shown enabled (show control messages)
R | toggles display of redundancy messages. In this example it's shown disabled (don't show redundancy messages)
W | toggles display of workstation status messages. This example shows it disabled (don't show workstation messages)

The "+" or "-" icon toggles and indicates whether the device numbers given in the following list are to be excluded or only those device numbers displayed.

As indicated in the example, BNCS device numbers 1, 2, 3 and 4 are to be excluded from the display.

Read it as
: exclude the following
: only show the following

For normal, unfiltered operation this list should be empty and indicating the "minus" icon.

UI Colours

These are configurable on a machine-by-machine basis (to suit the user) and the values are persisted in the Windows registry: HKEY_CURRENT_USER\Software\BNCS\bncs_netViewer.

Background colour changes are immediate, command/revertive/redundancy changes from next received message

Version Control

Version | Date | Author | Comments
2.0.0.6 | 09/10/2017 | DY | Not sure why this app didn't have independent version information - so here it is. This version adds store of window position and adds "Always on top" option
2.0.0.7 | 17/10/2017 | DY | Adds pause to toolbar so that this is more readily used on a touchscreen. Still not as handy as touching on the log view itself, but marginally easier to use
2.0.0.8 | 19/10/2017 | DY | Adds flippin' obvious warning about lack of OSPL_URI instead of obscure message from DDS
2.0.0.9 | 24/10/2017 | DY | Router database support (for slink/fabian site linking apps to stop name changes going up own a**e)
2.0.0.10 | 26/10/2017 | DY | Removes router database, and allows for loop-free RM
2.0.0.11 | 02/11/2017 | DY | Adds NV (Net slaVe) indication to go with redundancy mastering
2.0.12.0 | 21/11/2017 | DY | Adds millisecond value to disk log (I'm not sure why this didn't always have it). Also changes "significance" of last version digit to normal values (for this seat at least)
2.0.13.0 | 03/01/2018 | DY | Changes ordering of RM commands to "DDS CSI standard" i.e. ALWAYS device->index so RM 123 456 789 is device 123, index 456, database 789
2.0.14.0 | 04/01/2018 | DY | Adds commands with explanations
2.0.15.0 | 12/01/2018 | DY | Makes colours a configurable item and changes redundancy default to pink rather than a low-luminance purple it had been
2.0.16.0 | 16/01/2018 | DY | Fixes "always on top" (suddenly broken in Qt)
2.0.17.0 | 25/01/2018 | DY | Redundancy IDL change because second parameter is not always dest workstation
Build: master 3586 0d983c63 Atos © 2018