BNCS Driver: Sony Mixer Tally

BNCS Sony Mixer Driver

Description

This driver is from an original 16 bit application written by David Yates.

This driver was written to extract On-Air tally information from Sony 72xx series mixers (and may well work for some others as well !)

It is possible to get tally status for the separate banks of the mixer but this is not implemented in this driver.

v3sonyoa.exe is a 32 bit infodriver external application. It takes the BNCS device number as a command line parameter

Slot Allocation

All slots are read only.

Slot | Use | Read/Write | Notes
1 – 128 On – Air cue for input channels 1 – 128 Readonly 0 = Not On-Air
1 = On-Air
4094 Comms Fail Readonly 0 = Ok
1 = Fail
4095 Anything written here is echoed to slot 4096 Read/Write This setting must be made to allow this to work:
[Device]
GoRXOnlyOnExternalFail=0
4096 | Anything written here is echoed to slot 4095 | Read/Write | See above

Configuration

The following settings are required in the DEV_nnn.INI file (where nnn is the BNCS device number supplied as the command line parameter): Default entries are created if they do not exist.

Entry/Default | Notes
[Configuration] | Section for the Comms settings for this driver
Com=1 | Com Port to use
Speed=38400 | Baud Rate
DataBits=8 | Number of databits
StopBits=1 | Number of stop bits
Parity=O | Parity
XOnXOff=0 | Software Handshaking
Hardware=0 | Hardware Handshaking
[Device]
Name=Default | This appears on the driver dialog to help identify this driver
GoRXOnlyOnExternalFail=0 | The historic interfacing libraries used mean that this setting must be 0 in order for the ping/pong slots (4095/4096) to work

Version Information

As lodged with the source code (so not necessarily pretty) here
Written by David Yates. Copyright Atos 2012


3.1.4 - first versioned v3 release (dunno what happened to the rest of the version history....)
          changes constants for PurgeComm so that they do the intended thing (porting error)
          this was also intended as a "push characters to port" rather than a "clear characters from queue"
          this probably explains why comms reset doesn't work (character written but then immediately purged)
          NOTE: blind fix - I've nothing to test this with!
3.2.0 - Above blind fix now tested on real device.
        Minor refactoring and changes the parser to include all 128 possible tallies not just the first 64
        changes input buffer to never-can-be-exceeded values
        removes redundant variables
        THIS DRIVER SHOULD NEVER HAVE BEEN PORTED BORLAND TO BORLAND - there's so little actual driver code
        here that a reimplementation would have been appropriate
        adds comms fail slot (slot 4094)
        adds ping pong slots (4095/4096)
3.3.0 - tested TC3 - timing issue on sending select (0x30) after break
3.4.0 - another porting triumph....return value of open port wasn't being checked properly