BNCS Single V4.5 Panel Host

BNCS V4.5 Panel Host Launch Helper

Description

This is a helper application to launch v4.5 panels where no v4.5 environment exists on a BNCS V3 system.

This application has no UI - it just prepares the environment, runs a V4.5 UI application and then exits.

The application starts life as bncs_client_helper.exe but should be renamed to be the same as the directory of the V4.5 panel to run (v4.5 UIs are one UI per directory - this keeps everything together when the UI has many elements i.e. dialogs, script, bitmaps etc.).

Environment

This application is written to set:

Element | Derived from
Environment variable CC_WORKSTATION | Copied from csi.ini in usual V3 config path
Environment variable CC_ROOT | No V3 equivalent - see "V3 configuration" below
Environment variable CC_SYSTEM | No V3 equivalent - see "V3 configuration" below
Windows Path The path is prepended with a value equivalent to:
%CC_ROOT%\%CC_SYSTEM%\windows\lib

Application

The application run is "bncs_v45_host.exe" - a v4.5 UI host that runs a single UI application (documented elsewhere)

Having prepared the environment the following application is run:

%CC_ROOT%\%CC_SYSTEM%\panels\bncs_v45_host.exe

(where CC_ROOT/CC_SYSTEM are the values defined in c:\bncs_config.ini). The panels subdirectory in this path is fixed.

The command line parameter for the bncs_v4.5_host application is the V4.5 UI to load. This helper application does not have this defined or configured explicitly but for ease of use is the same as the name of this application.

Here's an example: a minimalist panels directory for a V3 system - it contains the bncs_v45_host.exe which cannot be run directly since this v3 workstation doesn't have a v4.5 install on it (try to run it and you'll get a message to that effect).

The V4.5 UI is contained in the directory test - so to load that up we rename this application (bncs_client_helper.exe) to be test.exe and run that. This prepares the environment and runs the V4.5 UI from the folder of the same name.

This application (test.exe) then exits leaving bncs_v45_host.exe behaving like an ApplCore UI - i.e. correct title bar for application switching etc.

V3 Configuration

We need to know the path to our system - whilst V4.5 defines where to look with its environment variables there is no direct V3 equivalent and isn't safe or useful to derive from anything else.

The following additional entries are required in V3's bncs_config.ini file:

[Config]
SystemPath=C:\Windows
ConfigPath=C:\Windows
TempPath=c:\temp
CC_ROOT=c:
CC_SYSTEM=bncs

These are entries are not automatically created with default values in the c:\bncs_config.ini file.

If these entries are not present the values shown above are used.

Written by David Yates. Copyright Atos 2012