TSL_Tally_Set Component

The screen grab below shows two instances of the component in use.

Description

The TSL_Tally_Set component was designed for use as part of the BBC Academy Studio C BNCS control system. The installation uses a Miranda Kaleido-X Multiviewer to create the gallery displays. Those displays include status blocks for Reh/TX status, Houslights etc. A mechanism is required to activate these alerts. The Kaleido-X receives a feed of TSL UMD protocol in which the first 48 addresses are used for UMD text and tally. Addresses from 50 to 79 are available to signal miscellaneous properties.

The TSL_Tally_Set component is the interface between the source of the data and the TSL tally bit in a chosen UMD address. At design time the user drops the component into a BNCS Script component box sized at 180 x 140 pels. The user can then enter the required operational parameters into the script editor persisting values dialog. The parameters to be set are listed later in this help file.

The source of data can be either a GPI contact or an Infodriver slot. The driver ID and slot/contact are entered into the ref= field of an instance entry in the config/instances.xml file. An extra parameter must be added to the instance entry taking the form of either drvtype="g" (gpi contact) or drvtype="i" (Infodriver slot). If the parameter is omitted, the component will default to infodriver mode and an error report is sent to the system debug log. The type of driver is shown by the first box of the third row of the component mimic display, with the driver ID in the box to the immediate right. The GPI contact or Infodriver slot number extracted from the instance entry is shown to the right of the Index box on row 3. The TSL UMD address used to transport the flag(s) is shown on Row 2 of the mimic.

The driver ID of the BNCS TSL UMD driver and the UMD address to be used for signalling are also an entry in instances.xml (using the ref= entry), but this does not need the devtype= element.

Commands

Name | Type | Use
instance | mandatory | The driver id and slot/contact to be monitored. Remember to include the extra devtype= entry to specify the type of driver to monitor. Driver type, BNCS ID and slot/contact read from entry are displayed on the component mimic row 3.
monitoring | mandatory | Place a name here that reflects the function of the component function. The name is shown in the label slot at the top of the component mimic. The label is set for smart text, so long names display in small letters.
setslot | mandatory | The name of the entry in instances.xml that holds the infodriver ID and TSL address whose tally is set.
slotoffset | mandatory | This value is added to the setslot parameter to form the infodriver slot number that controls the TSL tally bit(s). Typically this is 1000 for the BNCS TSL UMD driver.
tally_on | mandatory | The value in the slot/contact that sets the tally to "on". For a GPI contact the only values should be 0 or 1. For an infodriver slot the value is the text that should be in that slot to trigger the tally on state.
tally_val | mandatory | The value to be set in tally bits when the "On" condition is met. The value 0 is sent when the condition for "tally on" is not active. Values 1,2,3 are possible values for TSL UMD protocol.

Notifications

None

Stylesheets

None

Developers Notes

Setting tally_on to 0 for a GPI contact means the active output state will be set when the contact is at a 0, effectively acting as an invert compared to setting tally_on to 1.
Copyright BBC 2017