MLDestMimic Component

Component: MLDestMimic

Description

This scripted component is designed for use as a tally/mimic display within a component that provides destination control in a multi-level router system.

The author of the parent of this component sends it data to define the BNCS driver ID and destination output it should monitor for source selection data. If the level is unused by the destination (ie a specific matrix is not used) or if the destination or matrix ID are invalid a text message replaces the source name display. The text to display is sent from the host component, as is the statesheet name that controls the look of the display.

Commands

Name | Type | Use
driverid | required | BNCS driver number for this level of the multi-levelsystem.
destid | required | The matrix destination number for this level.
statesheet | required | The stylesheet name that defines the mimic name look.
unusedtext | recommended | Text to show if this level is not used by a destination. If this is not provided, the default is to show "unknown".

Notifications

None

Stylesheets

No predefined statesheets are used. Statesheet value is passed from script host to this component.

Developers Notes

This component was developed for use in multi-level destinations. The parent of this component sends it the statesheet name that controls the look of the display, the BNCS driver ID and destination ID to monitor, and the text to display when the level monitored by this component is not used by a package. Database 0 is used to fetch the name of sources.
Copyright BBC 2017