RxTx Automatic

RxTx

Description

RxTx is an automatic scripted panel used in Wood Norton Studio C.

There are two galleries (Gallery A and Gallery C) and several TV studio spaces - Studio A and Studio B floors are adjacent and connected, Studio C floor, Studio C News (a small down-the-line contribution area). The control and signal infrastructure was designed such that either gallery could use any of the studio spaces, and hence the control of the rehearse and transmission indicators must support the flexible use.

There is a partner automatic that runs on a computer in the Central Technical Area (CTA) which houses the Studio A equipment. It switches the lights for Studio A and B floors, whilst RxTx in Studio C controls the Studio C gallery indicators, the Studio C floor indicators and the Studio C News indicators.

Each studio signals it's status via a slot in an infodriver (known as the Tally Infodriver). Three values are supported for each slot - 0 indicates neither rehearse or transmit, 1 indicates rehearse mode, 2 indicates transmit mode. Three further slots record the control allocation for the studio spaces. When gallery C enters Transmit mode the signal output routing is forced to standard, clearing down settings such as colour bars to line. Full audio control is still to be implemented once BNCS control of the Studer sound desk is implemented.

The automatic panel hosts several indicators, most of which use BNCS enum buttons to read and display the values from the Tally Infodriver or the GPI crate. The Studio C Floor, News Studio and Studio A and B Floor indicators are driven by the code in RxTx. The standard audio and video outputs are read from instances.xml. See the C++ code for the names of the instances. The screen grab of the automatic panel was made with Studio C set to rehearse mode.

Commands

None.

Notifications

None.

Stylesheets

Name | Use
WN_Studio_OFF | Sets colour of block when neither Reh nor Tx active.
WN_Studio_REH | Sets colour of block when Rehearse is active.
WN_Studio_TX | Sets colour of block when Transmit is active.

Developers Notes

Still thinking ...
Copyright BBC 2017