bncs_install

BNCS Installation / Updating

Installation Tasks

The installers cover:

  1. the basic V4.x environment on a workstation
  2. the system-update mechanism to make a workstation part of a larger system
  3. the installation/update of a full set of applications
  4. the installation/update of core UI components
  5. the installation/update of a demonstration system

1 & 2 are likely to be on site, deploying a basic workstation configuration. Once a system is up-and-running, the current live system is not "installed" as such, but updated from a system server
3, 4 & 5 are likely to install and update a developer's machine. To try stuff out or to update to a new release. The developer then updates the master system server as appropriate to deploy any changes to to the live system.

Installers

There are 5 different installers

  1. Full Installer for demonstration/developer/evaluation
  2. Binaries
  3. Core UI components
  4. Demonstration System Configuration
  5. Workstation install

To make things easy, and as a one-stop shop, the full installer does environment & demonstration system

To be able to positively identify installers of a particular build they're stamped with the branch and revision number from source control. So you'll see filenames like: bncs_fullInstall_trunk_3557.exe telling me that it's the main code line (the trunk) and revision 3557. You can then easily tell what's what.

The workstation install (for when you want to deploy a system on site) is not included in this installer package but is part of the binaries that are included in the full or binaries installer

To install a system to try...

Run the "full installer", select all the options (master system, components etc. etc). Set as workstation 1 or 2 (which is NetBIOS CSI or DDS CSI otherwise they're the same). Default resolution is 1280x1024.

Note The application path you select in this installer is the root of one or more BNCS systems. The system name you select separately is then a sub-folder off this path.

Before Updating...

Copy your existing system (or fully committed to source control if you use it).

Updating an existing system to a new release

Run the binaries installer - this will give you a complete set of the executables used to make a V4.5+ system. The path you select is for the actual system to update - so if your systems live in "c:\bncs" and your system name is "mySystem" then the path to use is "c:\bncs\mySystem".

This will ask to run the update helper app which will move stuff about, correct settings, maybe even delete stuff so that all the files/settings are in the right place for the binaries that you're about to use. This doesn't do anything it shouldn't or you can skip - you can always compare with your back-up copy (you took a copy right?)

After updating:

  • run the bncs_buildTool and re-build the source folder
  • run the bncs_buildTool and re-build the panels folder

Note: some systems have applications in the source folder that rely on libraries also in the source folder. So you can either run the bncs_buildTool on specific parts of the source folder (e.g. source\windows\lib before source\windows\bin) or just run the bncs_buildTool twice on the source path.

This installer only contains executables, libraries and associated headers - your existing panels & configuration aren't touched.

Note: Do not be tempted to take bits-and-pieces of an updated system and apply it to another one - this is just asking for things to not work properly (a bit of DLL-hell).

Note: Do not be tempted to "save time" by not rebuilding your UI projects having updated the system binaries. Using bncs_buildTool makes a rebuild trivial to do.

Updating the core UI components

These are separately released so that you can update just your core_components independently of anything else. You must however then build the updated source code to match the binaries on your system. Again, it's bncs_buildTool that makes this easy.

The path to use on the installer is the full path to your system.

Note: You must not have done any local modifictions of applications contained within the core_components directory. You can reuse/modify and adapt any of these components, but you must have done it on your own local copy of the code.

We try very hard to keep source compatability between the UI release and the core code release, but occasionally you might find that something that has a particular dependency

Master / Demonstration System

This is a stand-alone system that demonstrates how a system goes together and has a full set of workstations, configuration, panels etc. to make something work.

The path to use on the installer is the full path to your system.

Note: This will overwrite configuration on your existing system - giving you the demo-system list of workstaions, applications and associated configuration. So, don't install it over the top of a system that you wanted to keep.

As it's just configuration and panel source-code you can apply the master/demo system over the top of another system if you want to try exercising the binaries of an existing system against a known configuration.

Uninstalling BNCS

Files

BNCS V4.x mosty installs to a single tree - you can just remove that.

The BNCS utility runVisEd.exe is added to the Windows directory and can be removed

Environment Variables

The following environment variables are also added and can be manually removed:

  • CC_DEVELOPER
  • CC_ROOT
  • CC_SYSTEM
  • CC_SERVER_ROOT
  • CC_RESERVE_SERVER_ROOT
  • CC_WORKSTATION

and being very careful with this one the following are added to the PATH variable and can be removed:

  • %CC_ROOT%\%CC_SYSTEM%\windows\bin
  • %CC_ROOT%\%CC_SYSTEM%\windows\lib

Registry

The following registry paths/keys are added by the installer (though this is not a comprehensive list of everything every BNCS app might use)

  • HKEY_CLASSES_ROOT.bncs_ui
  • HKEY_CLASSES_ROOT\BNCS_UI_File
Build: bncs_4.7.5 5800 a1b48197a Atos|Syntel © 2021