netLegacy

BNCS netLegacy DLL

Description

This is a helper DLL that provides a network interface to DDS for BNCS.

More information on what it does, how and why it doesn't is to be found in the documentation for bncs_csi (DDS CSI)

Version History

Version | Date | DDS Version | Notes
2.0.x.x |  |  | Development versions
2.0.3.0 | 25/07/17 | 6.7OSS | Implements traffic counters
2.0.4.0 | 26/01/18 | 6.9 | changes to redundancy IDL to reflect the fact the second parameter is not always destWorkstation
2.0.5.0 | 23/10/18 | 6.9 | Adds database field to the data key
2.0.6.0 | 30/11/18 | 6.9 | Adds netStatus messaging channel
2.0.7.0 | 07/06/19 | 6.9 | Renames mis-named IDL fields. Adds generating workstation field for use by gateway
2.0.8.0 | 24/07/19 | 6.9 | Check of callback for those implementations (only test so far) that don't want to listen
2.0.9.0 | 26/11/19 | 6.9 | Correct setting of generating workstation field for those messages that didn't have it set (largely redundant for messages that won't get passed via the gateway eg. redundancy)
2.0.10.0 | 27/11/19 | 6.9 | Allows explicit creation of readers and writers
2.0.11.0 | 27/11/19 | 6.9 | Rationalisation of DDS participants
2.0.12.0 | 04/12/19 | 6.10.3 | Rebuilds against updated DDS libs
2.0.13.0 | 28/01/20 | none | Adds fields to the key for redundancy types (awaiting new DDS library for rebuild)
Build: bncs_4.7.5 5800 a1b48197a Atos|Syntel © 2021