echoStub

echoStub.exe

Description

This is a simple app that just echos the value of an infodriver write command.

It maintains no state, so you can't use it for any real purpose.

You can poll it, but it will only return the string: "echostub".

However, it's as simple as they come when it comes to presenting a BNCS device on the network, and is useful for testing.

Configuration

It hosts a single BNCS device, and takes the following command line parameter:

echoHost.exe 123
echoHost.exe /device=123

Version Control

Version | Date | Author | Comments
1.0.0.1 | 16/08/2019 | DY | Initial Version
1.0.0.2 | 28/08/2019 | DY | Adds app icon, fixes closedown crash on failed start
1.0.1.0 | 23/10/2019 | DY | Now returns "echostub" when polled (for simple testing purposes)
Build: bncs_4.7.5 5800 a1b48197a Atos|Syntel © 2021